Back to overview
Downtime
Some services are down
Feb 07 at 12:00am UTC
Affected services
scoutswap.co.uk
Resolved
Feb 18 at 09:59pm UTC
All service has been restored.
Affected services
Updated
Feb 07 at 07:06am UTC
Unfortunately delays with a Scouting treasurer has meant we can't pay the service fees at this moment. We should be back online in the next week.
Affected services
Created
Feb 07 at 12:00am UTC
We are aware of issues accessing the Service and are working hard to restore it.
Affected services